Friday, June 3, 2016

3.2.4.9 - Troubleshooting a VLAN Implementation Scenario 1

3.2.4.9 - Troubleshooting a VLAN Implementation Scenario 1



Objectives

Part 1: Test Connectivity between PCs on the Same VLAN
Part 2: Investigate Connectivity Problems by Gathering Data
Part 3: Implement the Solution and Test Connectivity

Scenario

In this activity, you will troubleshoot connectivity problems between PCs on the same VLAN. The activity is complete when PCs on the same VLAN can ping each other. Any solution you implement must conform to the Addressing Table.


Part 1:     Test Connectivity between PCs on the Same VLAN

From the command prompt on each PC, ping between PCs on the same VLAN.

a.     Can PC1 ping PC4?
no

b.    Can PC2 ping PC5?
no

c.     Can PC3 ping PC6?
no

Part 2:     Investigate Connectivity Problems by Gathering Data

Step 1:     Verify configuration on the PCs.


Verify if the following configurations for each PC is correct.

·         IP address
·         Subnet mask

PC1 through PC4- correct (but missing gateways)
PC5- wrong IP addres



Step 2:     Verify the configuration on the switches.

Verify if the following configurations on the switches are correct.

·         Ports assigned to the correct VLANs.
·         Ports configured for the correct mode.
·         Ports connected to the correct devices.

Checking S1

S1#show running-conf

!
interface GigabitEthernet0/1
switchport trunk native vlan 99  - correct
switchport mode access -  incorrect
!
interface GigabitEthernet0/2
switchport trunk native vlan 99 - correct
switchport mode trunk - correct
!
interface Vlan1
no ip address

shutdown




Checking S2

S2#show vlan

VLAN Name Status Ports
---- -------------------------------- --------- -------------------------------
10 Faculty/Staff active- no ports assigned
20 Students active Fa0/18

30 Guest(Default) active Fa0/6, Fa0/11 - incorrect, should belong to VLAN 10


S2#show running-config
!
interface FastEthernet0/6
switchport access vlan 30 - correct
switchport mode access - correct
!
!
interface FastEthernet0/11
switchport access vlan 30 - incorrect
switchport mode access - correct
!
!
interface FastEthernet0/18
switchport access vlan 20 - correct
switchport mode access - correct
!
!
interface GigabitEthernet0/1
switchport trunk native vlan 99
switchport mode access - incorrect
!
!
interface Vlan1
no ip address

shutdown




Checking S3

S3#show vlan

VLAN Name Status Ports
---- -------------------------------- --------- -------------------------------
10 Faculty/Staff active Fa0/11
20 Students active Fa0/6 - incorrect, should be in VLAN 30
30 Guest(Default) active Fa0/18 - incorrect, should be in VLAN 10


S3#show run

!
interface FastEthernet0/6
switchport access vlan 20 - incorrect
switchport mode access - correct
!
interface FastEthernet0/11
switchport access vlan 10 - correct
switchport mode access - correct
!
!
interface FastEthernet0/18
switchport access vlan 30 - incorrect
switchport mode access - correct
!
interface GigabitEthernet0/2
switchport trunk native vlan 99 - correct
switchport mode trunk - correct
!
interface Vlan1
no ip address
shutdown

!

Step 3:     Document the problem and the solutions.

List the problems and the solutions that will allow these PCs to ping each other. Keep in mind that there could be more than one problem or more than one solution.

Int g0/1 on S2 is in access mode.
Correcting:

S2(config)#int g0/1

S2(config-if)#switchport mode trunk

S1(config)#int g0/1

S1(config-if)#switchport mode trunk


PC1 to PC4


a.     Explain the connectivity issues between PC1 and PC4.

Incorrect vlan assignment on S2 interface FastEthernet0/11


b.    Record the necessary actions to correct the issues.

S2(config)#int f0/11

S2(config-if)#switchport access vlan 10


PC2 to PC5


c.     Explain the connectivity issues between PC2 and PC5.

Incorrect vlan assignment on S3 interface FastEthernet0/18

d.    Record the necessary actions to correct the issues.

S3(config)#int f0/18

S3(config-if)#switchport access vlan 20

PC3 to PC6

e.     What are the reasons why connectivity failed between the PCs?
Incorrect IP assignment on PC 6
Incorrect vlan assignment on S3 interface FastEthernet0/6


f.     Record the necessary actions to correct the issues.

S3(config)#int f0/6

S3(config-if)#switchport access vlan 30


Part 3:     Implement the Solution and Test Connectivity

Verify PCs on the same VLAN can now ping each other. If not, continue to troubleshoot.

PC1 is pinging PC4
PC2 is not pinging PC5 (!!!!)
PC3 is pinging PC6

Troubleshooting

PCs on VLAN 20 are not talking

1. checking vlan assignment

S2(config)#do show vlan

VLAN Name Status Ports
---- -------------------------------- --------- -------------------------------
10 Faculty/Staff active Fa0/11 - correct
20 Students active Fa0/18 - correct

30 Guest(Default) active Fa0/6 - correct


S3(config)#do show vlan

VLAN Name Status Ports
---- -------------------------------- --------- -------------------------------
10 Faculty/Staff active Fa0/11 - correct
20 Students active Fa0/18 - correct

30 Guest(Default) active Fa0/6 - correct



2. Checking allowed vlans



S2(config)#do show interfaces trunk
Port Mode Encapsulation Status Native vlan
Gig0/1 on 802.1q trunking 99 - correct

Port Vlans allowed on trunk
Gig0/1 1-1005 - correct

Port Vlans allowed and active in management domain
Gig0/1 1,10,20,30,99 - correct

Port Vlans in spanning tree forwarding state and not pruned
Gig0/1 1,10,20,30,99 – correct
S3(config)#do show interface trunk
Port Mode Encapsulation Status Native vlan
Gig0/2 on 802.1q trunking 99 - correct

Port Vlans allowed on trunk
Gig0/2 1-1005 - correct

Port Vlans allowed and active in management domain
Gig0/2 1,10,20,30,99 - correct

Port Vlans in spanning tree forwarding state and not pruned
Gig0/2 1,10,20,30,99 – correct


S1#show interface trunk
Port Mode Encapsulation Status Native vlan
Gig0/1 on 802.1q trunking 99 - correct
Gig0/2 on 802.1q trunking 99 - correct

Port Vlans allowed on trunk
Gig0/1 1-1005 - correct
Gig0/2 1-1005 - correct

Port Vlans allowed and active in management domain
Gig0/1 1,10,20,30,99 - correct
Gig0/2 1,10,20,30,99 - correct

Port Vlans in spanning tree forwarding state and not pruned
Gig0/1 1,10,20,30,99  - correct
Gig0/2 1,10,20,30,99 - correct





3. Checking interfaces f0/18 on both sides


S2# show int f0/18
FastEthernet0/18 is up, line protocol is up (connected)

S3#show int f0/18
FastEthernet0/18 is down, line protocol is down (disabled)


4. Checking the links on S3

S3(config)#do show ip interface brief

FastEthernet0/16 unassigned YES manual down down

FastEthernet0/17 unassigned YES manual up up




FastEthernet0/18 unassigned YES manual down down


5. Checking topology:
Conclusion:
Topology label is incorrect. PC5 is actually connected to F0/17

Solution
Connect PC to f0/18 as specified in the topology

%LINK-5-CHANGED: Interface FastEthernet0/17, changed state to down

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/17, changed state to down

%LINK-5-CHANGED: Interface FastEthernet0/18, changed state to up


%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/18, changed state to up

Result
PC3 is now pinging PC6 successfully


Lab completed




--------------

Switch 1

spanning-tree mode pvst
!
interface FastEthernet0/1
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
switchport trunk native vlan 99
switchport mode trunk
!
interface GigabitEthernet0/2
switchport trunk native vlan 99
switchport mode trunk
!
interface Vlan1
no ip address

shutdown




Switch 2

spanning-tree mode pvst
!
interface FastEthernet0/1
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
switchport access vlan 30
switchport mode access
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
switchport access vlan 20
switchport mode access
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
switchport trunk native vlan 99
switchport mode trunk
!
interface GigabitEthernet0/2
!
interface Vlan1
no ip address

shutdown



Switch 3

spanning-tree mode pvst
!
interface FastEthernet0/1
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
switchport access vlan 30
switchport mode access
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
switchport access vlan 20
switchport mode access
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
switchport trunk native vlan 99
switchport mode trunk
!
interface Vlan1
no ip address
shutdown

!

No comments:

Post a Comment