3.2.4.8 - Troubleshooting a VLAN Implementation Scenario 2
Objectives
Part 1: Find and Correct the Network Errors
Part 2: Document the Corrections to the Network
Part 3: Implement Solutions and Test Connectivity
Background
In this activity, you will troubleshoot a misconfigured VLAN environment. The initial network has errors. Your objective is to locate and correct the errors in the configurations and establish end-to-end connectivity. Your final configuration should match the Topology diagram and Addressing Table. The native VLAN for this topology is VLAN 56.
Part 1: Discover and Document Issues in the Network Use the Topology, Addressing Table, VLAN and Port Assignments table and your knowledge of VLANs and trunking to discover issues in the network. Complete the Documentation table listing the problems you discovered and potential solutions.
Part 2: Implement the Solution and Test Connectivity
Verify PCs on the same VLAN can now ping each other. If not, continue to troubleshoot
- all PCs are now pinging PCs in their VLANs
------------------------
Switch 1
interface GigabitEthernet0/1
switchport trunk native vlan 56
switchport mode trunk
!
interface GigabitEthernet0/2
switchport trunk native vlan 56
switchport mode trunk
Switch 2
interface FastEthernet0/1
switchport access vlan 56
switchport trunk native vlan 56
switchport mode access
!
interface FastEthernet0/2
switchport access vlan 56
switchport trunk native vlan 56
switchport mode access
!
interface FastEthernet0/3
switchport access vlan 56
switchport trunk native vlan 56
switchport mode access
!
interface FastEthernet0/4
switchport access vlan 56
switchport trunk native vlan 56
switchport mode access
!
interface FastEthernet0/5
switchport access vlan 56
switchport trunk native vlan 56
switchport mode access
!
interface FastEthernet0/6
switchport access vlan 30
switchport mode access
!
interface FastEthernet0/7
switchport access vlan 30
switchport mode access
!
interface FastEthernet0/8
switchport access vlan 30
switchport mode access
!
interface FastEthernet0/9
switchport access vlan 30
switchport mode access
!
interface FastEthernet0/10
switchport access vlan 30
switchport mode access
!
interface FastEthernet0/11
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/12
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/13
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/14
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/15
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/16
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/17
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/18
switchport access vlan 20
switchport mode access
!
interface FastEthernet0/19
switchport access vlan 20
switchport mode access
!
interface FastEthernet0/20
switchport access vlan 20
switchport mode access
!
interface FastEthernet0/21
switchport access vlan 20
switchport mode access
!
interface FastEthernet0/22
switchport access vlan 20
switchport mode access
!
interface FastEthernet0/23
switchport access vlan 20
switchport mode access
!
interface FastEthernet0/24
switchport access vlan 20
switchport mode access
!
interface GigabitEthernet0/1
switchport trunk native vlan 56
switchport mode trunk
!
interface GigabitEthernet0/2
!
interface Vlan1
no ip address
shutdown
!
interface Vlan56
ip address 192.168.56.12 255.255.255.0
Switch 3
interface FastEthernet0/1
switchport access vlan 56
switchport mode access
!
interface FastEthernet0/2
switchport access vlan 56
switchport mode access
!
interface FastEthernet0/3
switchport access vlan 56
switchport mode access
!
interface FastEthernet0/4
switchport access vlan 56
switchport mode access
!
interface FastEthernet0/5
switchport access vlan 56
switchport mode access
!
interface FastEthernet0/6
switchport access vlan 30
switchport mode access
!
interface FastEthernet0/7
switchport access vlan 30
switchport mode access
!
interface FastEthernet0/8
switchport access vlan 30
switchport mode access
!
interface FastEthernet0/9
switchport access vlan 30
switchport mode access
!
interface FastEthernet0/10
switchport access vlan 30
switchport mode access
!
interface FastEthernet0/11
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/12
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/13
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/14
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/15
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/16
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/17
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/18
switchport access vlan 20
switchport mode access
!
interface FastEthernet0/19
switchport access vlan 20
switchport mode access
!
interface FastEthernet0/20
switchport access vlan 20
switchport mode access
!
interface FastEthernet0/21
switchport access vlan 20
switchport mode access
!
interface FastEthernet0/22
switchport access vlan 20
switchport mode access
!
interface FastEthernet0/23
switchport access vlan 20
switchport mode access
!
interface FastEthernet0/24
switchport access vlan 20
switchport mode access
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
switchport trunk native vlan 56
switchport mode trunk
!
interface Vlan1
no ip address
shutdown
!
interface Vlan56
ip address 192.168.56.13 255.255.255.0
Objectives
Part 1: Find and Correct the Network Errors
Part 2: Document the Corrections to the Network
Part 3: Implement Solutions and Test Connectivity
Background
In this activity, you will troubleshoot a misconfigured VLAN environment. The initial network has errors. Your objective is to locate and correct the errors in the configurations and establish end-to-end connectivity. Your final configuration should match the Topology diagram and Addressing Table. The native VLAN for this topology is VLAN 56.
Part 1: Discover and Document Issues in the Network Use the Topology, Addressing Table, VLAN and Port Assignments table and your knowledge of VLANs and trunking to discover issues in the network. Complete the Documentation table listing the problems you discovered and potential solutions.
PROBLEM | SOLUTION |
From show running-config interface GigabitEthernet0/1 switchport trunk native vlan 56 switchport mode access |
S2(config)# int g0/1 S2(config-if)#switchport mode trun |
From show interface trunk Native VLAN on S1 = Vlan1 Native VLAN on S2 = Vlan56 |
S1(config)#int g0/1 S1(config-if)#switchport trunk native vlan 56 |
From show interface trunk Native VLAN on S1 = Vlan1 Native VLAN on S3 = Vlan56 |
S1(config)#int g0/2 S1(config-if)#switchport trunk native vlan 56 |
From show vlan: All ports on S3 are assigned to Vlan1 |
S3(config)#int range f0/1-5 S3(config-if-range)#switchport mode access S3(config-if-range)#switchport access vlan 56 S3(config-if-range)#exit S3(config)#int range f0/6-10 S3(config-if-range)#switchport mode access S3(config-if-range)#switchport access vlan 30 S3(config-if-range)#exit S3(config)#int range f0/11-17 S3(config-if-range)#switchport mode access S3(config-if-range)#switchport access vlan 10 S3(config-if-range)#exit S3(config)#int range f0/18-24 S3(config-if-range)#switchport mode access S3(config-if-range)#switchport access vlan 20 S3(config-if-range)#exit |
From show interface trunk S1 allowed VLANs in management domain lists only Vlan1 From show vlan: S1 does not have vlans 10, 20, 30, 56 created |
S1(config)#vlan 10 S1(config-vlan)#name Faculty S1(config-vlan)#exit S1(config)#vlan 20 S1(config-vlan)#name Students S1(config-vlan)#exit S1(config)#vlan 30 S1(config-vlan)#name Guests S1(config-vlan)#exit S1(config)#vlan 56 S1(config-vlan)# %LINK-5-CHANGED: Interface Vlan56, changed state to up %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan56, changed state to up S1(config-vlan)#name Management&Native |
Part 2: Implement the Solution and Test Connectivity
Verify PCs on the same VLAN can now ping each other. If not, continue to troubleshoot
- all PCs are now pinging PCs in their VLANs
------------------------
Switch 1
interface GigabitEthernet0/1
switchport trunk native vlan 56
switchport mode trunk
!
interface GigabitEthernet0/2
switchport trunk native vlan 56
switchport mode trunk
Switch 2
interface FastEthernet0/1
switchport access vlan 56
switchport trunk native vlan 56
switchport mode access
!
interface FastEthernet0/2
switchport access vlan 56
switchport trunk native vlan 56
switchport mode access
!
interface FastEthernet0/3
switchport access vlan 56
switchport trunk native vlan 56
switchport mode access
!
interface FastEthernet0/4
switchport access vlan 56
switchport trunk native vlan 56
switchport mode access
!
interface FastEthernet0/5
switchport access vlan 56
switchport trunk native vlan 56
switchport mode access
!
interface FastEthernet0/6
switchport access vlan 30
switchport mode access
!
interface FastEthernet0/7
switchport access vlan 30
switchport mode access
!
interface FastEthernet0/8
switchport access vlan 30
switchport mode access
!
interface FastEthernet0/9
switchport access vlan 30
switchport mode access
!
interface FastEthernet0/10
switchport access vlan 30
switchport mode access
!
interface FastEthernet0/11
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/12
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/13
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/14
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/15
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/16
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/17
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/18
switchport access vlan 20
switchport mode access
!
interface FastEthernet0/19
switchport access vlan 20
switchport mode access
!
interface FastEthernet0/20
switchport access vlan 20
switchport mode access
!
interface FastEthernet0/21
switchport access vlan 20
switchport mode access
!
interface FastEthernet0/22
switchport access vlan 20
switchport mode access
!
interface FastEthernet0/23
switchport access vlan 20
switchport mode access
!
interface FastEthernet0/24
switchport access vlan 20
switchport mode access
!
interface GigabitEthernet0/1
switchport trunk native vlan 56
switchport mode trunk
!
interface GigabitEthernet0/2
!
interface Vlan1
no ip address
shutdown
!
interface Vlan56
ip address 192.168.56.12 255.255.255.0
Switch 3
interface FastEthernet0/1
switchport access vlan 56
switchport mode access
!
interface FastEthernet0/2
switchport access vlan 56
switchport mode access
!
interface FastEthernet0/3
switchport access vlan 56
switchport mode access
!
interface FastEthernet0/4
switchport access vlan 56
switchport mode access
!
interface FastEthernet0/5
switchport access vlan 56
switchport mode access
!
interface FastEthernet0/6
switchport access vlan 30
switchport mode access
!
interface FastEthernet0/7
switchport access vlan 30
switchport mode access
!
interface FastEthernet0/8
switchport access vlan 30
switchport mode access
!
interface FastEthernet0/9
switchport access vlan 30
switchport mode access
!
interface FastEthernet0/10
switchport access vlan 30
switchport mode access
!
interface FastEthernet0/11
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/12
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/13
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/14
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/15
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/16
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/17
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/18
switchport access vlan 20
switchport mode access
!
interface FastEthernet0/19
switchport access vlan 20
switchport mode access
!
interface FastEthernet0/20
switchport access vlan 20
switchport mode access
!
interface FastEthernet0/21
switchport access vlan 20
switchport mode access
!
interface FastEthernet0/22
switchport access vlan 20
switchport mode access
!
interface FastEthernet0/23
switchport access vlan 20
switchport mode access
!
interface FastEthernet0/24
switchport access vlan 20
switchport mode access
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
switchport trunk native vlan 56
switchport mode trunk
!
interface Vlan1
no ip address
shutdown
!
interface Vlan56
ip address 192.168.56.13 255.255.255.0
No comments:
Post a Comment