Wednesday, June 8, 2016

3.2.2.4 Lab - Troubleshooting EtherChannel

This lab took me almost 4 hours to complete.
What I had to correct - mismatch in allowed vlans, mismatch in protocol versus mode, mismatch in port-channels.

Problems encountered:

  1. allowed vlans under show interface trunk did not match those shown on show run, and to correct I had to strip all trunk settings and start anew. 
  2. grouping protocols were staying incorrectly assigned. Like it would show Po1 PAgP, f0/3 Active, F0/4 Active, and on the next channel it would say Po2 LACP, f0/1 Desirable, f0/2 Desirable. And nothing except for deletion of port-channel itself would fix this mismatch. And after I fixed it, it would go straight back to incorrect mode/protocol combination under show etherchannel port-channel, while showing nothing wrong under show running
  3. spanning-tree is showing port channels AND their bundled links separately, attempting to block one of the links on each port-channel. In the process it somehow also managed to have 2 root switches for the same vlans. Until I fixed the mismatch in channel protocols, spanning-tree was looking weird.


I do not know what %%EC-5-COMPATIBLE: Fa0/3 is compatible with port-channel members
 means, but it kept popping up. Right now PCs are pinging one another, so whatever %%EC-5-COMPATIBLE: Fa0/3 is compatible with port-channel members means, it is not obstructing the connection.



Switch 1


hostname S1
!
!
!
no ip domain-lookup
!
!
spanning-tree mode pvst
!
interface FastEthernet0/1
switchport trunk native vlan 99
switchport trunk allowed vlan 1,10,99
channel-group 1 mode active
switchport mode trunk
!
interface FastEthernet0/2
switchport trunk native vlan 99
switchport trunk allowed vlan 1,10,99
channel-group 1 mode active
switchport mode trunk
!
interface FastEthernet0/3
switchport trunk native vlan 99
channel-group 2 mode desirable
switchport mode trunk
!
interface FastEthernet0/4
switchport trunk native vlan 99
channel-group 2 mode desirable
switchport mode trunk
!
interface FastEthernet0/5
shutdown
!
interface FastEthernet0/6
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/7
shutdown
!
interface FastEthernet0/8
shutdown
!
interface FastEthernet0/9
shutdown
!
interface FastEthernet0/10
shutdown
!
interface FastEthernet0/11
shutdown
!
interface FastEthernet0/12
shutdown
!
interface FastEthernet0/13
shutdown
!
interface FastEthernet0/14
shutdown
!
interface FastEthernet0/15
shutdown
!
interface FastEthernet0/16
shutdown
!
interface FastEthernet0/17
shutdown
!
interface FastEthernet0/18
shutdown
!
interface FastEthernet0/19
shutdown
!
interface FastEthernet0/20
shutdown
!
interface FastEthernet0/21
shutdown
!
interface FastEthernet0/22
shutdown
!
interface FastEthernet0/23
shutdown
!
interface FastEthernet0/24
shutdown
!
interface GigabitEthernet0/1
shutdown
!
interface GigabitEthernet0/2
shutdown
!
interface Port-channel 1
switchport trunk native vlan 99
switchport trunk allowed vlan 1,10,99
switchport mode trunk
!
interface Port-channel 2
switchport trunk native vlan 99
switchport trunk allowed vlan 1,10,99
switchport mode trunk
!
interface Vlan1
no ip address
shutdown
!
interface Vlan99
ip address 192.168.1.11 255.255.255.0

!



Switch 2


hostname S2
!
!
!
!
!
spanning-tree mode pvst
spanning-tree vlan 1,10,99 priority 24576
!
interface FastEthernet0/1
switchport trunk native vlan 99
channel-group 1 mode active
switchport mode trunk
!
interface FastEthernet0/2
switchport trunk native vlan 99
channel-group 1 mode active
switchport mode trunk
!
interface FastEthernet0/3
switchport trunk native vlan 99
channel-group 3 mode desirable
switchport mode trunk
!
interface FastEthernet0/4
switchport trunk native vlan 99
channel-group 3 mode desirable
switchport mode trunk
!
interface FastEthernet0/5
shutdown
!
interface FastEthernet0/6
shutdown
!
interface FastEthernet0/7
shutdown
!
interface FastEthernet0/8
shutdown
!
interface FastEthernet0/9
shutdown
!
interface FastEthernet0/10
shutdown
!
interface FastEthernet0/11
shutdown
!
interface FastEthernet0/12
shutdown
!
interface FastEthernet0/13
shutdown
!
interface FastEthernet0/14
shutdown
!
interface FastEthernet0/15
shutdown
!
interface FastEthernet0/16
shutdown
!
interface FastEthernet0/17
shutdown
!
interface FastEthernet0/18
shutdown
!
interface FastEthernet0/19
shutdown
!
interface FastEthernet0/20
shutdown
!
interface FastEthernet0/21
shutdown
!
interface FastEthernet0/22
shutdown
!
interface FastEthernet0/23
shutdown
!
interface FastEthernet0/24
shutdown
!
interface GigabitEthernet0/1
shutdown
!
interface GigabitEthernet0/2
shutdown
!
interface Port-channel 1
switchport trunk native vlan 99
switchport trunk allowed vlan 1,10,99
switchport mode trunk
!
interface Port-channel 3
switchport trunk native vlan 99
switchport trunk allowed vlan 1,10,99
switchport mode trunk
!
interface Vlan1
no ip address
shutdown
!
interface Vlan99

ip address 192.168.1.12 255.255.255.0



Switch 3


hostname S3
!
!
!
!
!
spanning-tree mode pvst
!
interface FastEthernet0/1
switchport trunk native vlan 99
channel-group 3 mode desirable
switchport mode trunk
!
interface FastEthernet0/2
switchport trunk native vlan 99
channel-group 3 mode desirable
switchport mode trunk
!
interface FastEthernet0/3
switchport trunk native vlan 99
switchport trunk allowed vlan 1,10
channel-group 2 mode desirable
switchport mode trunk
!
interface FastEthernet0/4
switchport trunk native vlan 99
switchport trunk allowed vlan 1,10
channel-group 2 mode desirable
switchport mode trunk
!
interface FastEthernet0/5
shutdown
!
interface FastEthernet0/6
shutdown
!
interface FastEthernet0/7
shutdown
!
interface FastEthernet0/8
shutdown
!
interface FastEthernet0/9
shutdown
!
interface FastEthernet0/10
shutdown
!
interface FastEthernet0/11
shutdown
!
interface FastEthernet0/12
shutdown
!
interface FastEthernet0/13
shutdown
!
interface FastEthernet0/14
shutdown
!
interface FastEthernet0/15
shutdown
!
interface FastEthernet0/16
shutdown
!
interface FastEthernet0/17
shutdown
!
interface FastEthernet0/18
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/19
shutdown
!
interface FastEthernet0/20
shutdown
!
interface FastEthernet0/21
shutdown
!
interface FastEthernet0/22
shutdown
!
interface FastEthernet0/23
shutdown
!
interface FastEthernet0/24
shutdown
!
interface GigabitEthernet0/1
shutdown
!
interface GigabitEthernet0/2
shutdown
!
interface Port-channel 2
switchport trunk native vlan 99
switchport trunk allowed vlan 1,10
switchport mode trunk
!
interface Port-channel 3
switchport trunk native vlan 99
switchport trunk allowed vlan 1,10,99
switchport mode trunk
!
interface Vlan1
no ip address
shutdown
!
interface Vlan99
ip address 192.168.1.13 255.255.255.0
!

!

Tuesday, June 7, 2016

3.2.1.4 - Configuring EtherChannel

https://static-course-assets.s3.amazonaws.com/ScaN503/en/course/files/3.2.1.4%20Lab%20-%20Configuring%20EtherChannel.pdf



Switch 1


hostname S1
!
!
!
!
!
spanning-tree mode pvst
!
interface FastEthernet0/1
switchport trunk native vlan 99
channel-group 2 mode active
switchport mode trunk
!
interface FastEthernet0/2
switchport trunk native vlan 99
channel-group 2 mode active
switchport mode trunk
!
interface FastEthernet0/3
switchport trunk native vlan 99
channel-group 1 mode desirable
switchport mode trunk
!
interface FastEthernet0/4
switchport trunk native vlan 99
channel-group 1 mode desirable
switchport mode trunk
!
interface FastEthernet0/5
shutdown
!
interface FastEthernet0/6
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/7
shutdown
!
interface FastEthernet0/8
shutdown
!
interface FastEthernet0/9
shutdown
!
interface FastEthernet0/10
shutdown
!
interface FastEthernet0/11
shutdown
!
interface FastEthernet0/12
shutdown
!
interface FastEthernet0/13
shutdown
!
interface FastEthernet0/14
shutdown
!
interface FastEthernet0/15
shutdown
!
interface FastEthernet0/16
shutdown
!
interface FastEthernet0/17
shutdown
!
interface FastEthernet0/18
shutdown
!
interface FastEthernet0/19
shutdown
!
interface FastEthernet0/20
shutdown
!
interface FastEthernet0/21
shutdown
!
interface FastEthernet0/22
shutdown
!
interface FastEthernet0/23
shutdown
!
interface FastEthernet0/24
shutdown
!
interface GigabitEthernet0/1
shutdown
!
interface GigabitEthernet0/2
shutdown
!
interface Port-channel 1
switchport trunk native vlan 99
switchport mode trunk
!
interface Port-channel 2
switchport trunk native vlan 99
switchport mode trunk
!
interface Vlan1
no ip address
shutdown
!
interface Vlan99

ip address 192.168.99.11 255.255.255.0




Switch 2

hostname S2
!
!
!
!
!
spanning-tree mode pvst
!
interface FastEthernet0/1
switchport trunk native vlan 99
channel-group 2 mode active
switchport mode trunk
!
interface FastEthernet0/2
switchport trunk native vlan 99
channel-group 2 mode active
switchport mode trunk
!
interface FastEthernet0/3
switchport trunk native vlan 99
channel-group 3 mode active
switchport mode trunk
!
interface FastEthernet0/4
switchport trunk native vlan 99
channel-group 3 mode active
switchport mode trunk
!
interface FastEthernet0/5
shutdown
!
interface FastEthernet0/6
shutdown
!
interface FastEthernet0/7
shutdown
!
interface FastEthernet0/8
shutdown
!
interface FastEthernet0/9
shutdown
!
interface FastEthernet0/10
shutdown
!
interface FastEthernet0/11
shutdown
!
interface FastEthernet0/12
shutdown
!
interface FastEthernet0/13
shutdown
!
interface FastEthernet0/14
shutdown
!
interface FastEthernet0/15
shutdown
!
interface FastEthernet0/16
shutdown
!
interface FastEthernet0/17
shutdown
!
interface FastEthernet0/18
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/19
shutdown
!
interface FastEthernet0/20
shutdown
!
interface FastEthernet0/21
shutdown
!
interface FastEthernet0/22
shutdown
!
interface FastEthernet0/23
shutdown
!
interface FastEthernet0/24
shutdown
!
interface GigabitEthernet0/1
shutdown
!
interface GigabitEthernet0/2
shutdown
!
interface Port-channel 2
switchport trunk native vlan 99
switchport mode trunk
!
interface Port-channel 3
switchport trunk native vlan 99
switchport mode trunk
!
interface Vlan1
no ip address
shutdown
!
interface Vlan99
ip address 192.168.99.12 255.255.255.0
!

!

Switch 3

hostname S3
!
!
!
!
!
spanning-tree mode pvst
!
interface FastEthernet0/1
switchport trunk native vlan 99
channel-group 3 mode active
switchport mode trunk
!
interface FastEthernet0/2
switchport trunk native vlan 99
channel-group 3 mode active
switchport mode trunk
!
interface FastEthernet0/3
switchport trunk native vlan 99
channel-group 1 mode auto
switchport mode trunk
!
interface FastEthernet0/4
switchport trunk native vlan 99
channel-group 1 mode auto
switchport mode trunk
!
interface FastEthernet0/5
shutdown
!
interface FastEthernet0/6
shutdown
!
interface FastEthernet0/7
shutdown
!
interface FastEthernet0/8
shutdown
!
interface FastEthernet0/9
shutdown
!
interface FastEthernet0/10
shutdown
!
interface FastEthernet0/11
shutdown
!
interface FastEthernet0/12
shutdown
!
interface FastEthernet0/13
shutdown
!
interface FastEthernet0/14
shutdown
!
interface FastEthernet0/15
shutdown
!
interface FastEthernet0/16
shutdown
!
interface FastEthernet0/17
shutdown
!
interface FastEthernet0/18
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/19
shutdown
!
interface FastEthernet0/20
shutdown
!
interface FastEthernet0/21
shutdown
!
interface FastEthernet0/22
shutdown
!
interface FastEthernet0/23
shutdown
!
interface FastEthernet0/24
shutdown
!
interface GigabitEthernet0/1
shutdown
!
interface GigabitEthernet0/2
shutdown
!
interface Port-channel 1
switchport trunk native vlan 99
switchport mode trunk
!
interface Port-channel 3
switchport trunk native vlan 99
switchport mode trunk
!
interface Vlan1
no ip address
shutdown
!
interface Vlan99
ip address 192.168.99.13 255.255.255.0

!






3.2.1.3 - Configuring EtherChannel

https://static-course-assets.s3.amazonaws.com/ScaN503/en/course/files/3.2.1.3%20Packet%20Tracer%20-%20Configuring%20EtherChannel%20Instructions.pdf

Switch 1


hostname S1
!
!
!
!
!
spanning-tree mode pvst
spanning-tree vlan 1 priority 24576
!
interface FastEthernet0/1
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
channel-group 1 mode desirable
switchport mode trunk
!
interface FastEthernet0/22
channel-group 1 mode desirable
switchport mode trunk
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
channel-group 2 mode active
switchport mode trunk
!
interface GigabitEthernet0/2
channel-group 2 mode active
switchport mode trunk
!
interface Port-channel 1
switchport mode trunk
!
interface Port-channel 2
switchport mode trunk
!
interface Vlan1
no ip address

shutdown



Switch 2


hostname S2
!
!
!
!
!
spanning-tree mode pvst
!
interface FastEthernet0/1
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
channel-group 3 mode passive
switchport mode trunk
!
interface FastEthernet0/24
channel-group 3 mode passive
switchport mode trunk
!
interface GigabitEthernet0/1
channel-group 2 mode active
switchport mode trunk
!
interface GigabitEthernet0/2
channel-group 2 mode active
switchport mode trunk
!
interface Port-channel 2
switchport mode trunk
!
interface Port-channel 3
switchport mode trunk
!
interface Vlan1
no ip address

shutdown



Switch 3

hostname S3
!
!
!
!
!
spanning-tree mode pvst
!
interface FastEthernet0/1
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
channel-group 1 mode desirable
switchport mode trunk
!
interface FastEthernet0/22
channel-group 1 mode desirable
switchport mode trunk
!
interface FastEthernet0/23
channel-group 3 mode passive
switchport mode trunk
!
interface FastEthernet0/24
channel-group 3 mode passive
switchport mode trunk
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Port-channel 1
switchport mode trunk
!
interface Port-channel 3
switchport mode trunk
!
interface Vlan1
no ip address

shutdown


Saturday, June 4, 2016

2.3.1.5 Packet Tracer lab - Configuring PVST+

This was an easy-cheasy lab and a great STP exercise. I got stumbled only once or so (had to look up the ? for my commands)


I am running out of the allotted data plan, so cannot post any images.

Switch 1


hostname S1
!
!
!
no ip domain-lookup
!
vtp mode transparent
!
!
spanning-tree mode pvst
spanning-tree vlan 1,10,30,50,70 priority 24576
!
vlan 10
!
vlan 20
!
vlan 30
!
vlan 40
!
vlan 50
!
vlan 60
!
vlan 70
!
vlan 80
!
vlan 99
!
interface FastEthernet0/1
switchport trunk native vlan 99
switchport mode trunk
!
interface FastEthernet0/2
switchport mode access
!
interface FastEthernet0/3
switchport mode access
!
interface FastEthernet0/4
switchport trunk native vlan 99
switchport mode trunk
!
interface FastEthernet0/5
!
interface FastEthernet0/6
switchport access vlan 30
switchport mode access
spanning-tree portfast
spanning-tree bpduguard enable
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
no ip address
shutdown
!
interface Vlan99
ip address 172.31.99.1 255.255.255.0

!

----------------

hostname S2

!
!
!
no ip domain-lookup
!
vtp mode transparent
!
!
spanning-tree mode pvst
spanning-tree vlan 1,10,20,30,40,50,60,70,80,99 priority 28672
!
vlan 10
!
vlan 20
!
vlan 30
!
vlan 40
!
vlan 50
!
vlan 60
!
vlan 70
!
vlan 80
!
vlan 99
!
interface FastEthernet0/1
switchport trunk native vlan 99
switchport mode trunk
!
interface FastEthernet0/2
switchport trunk native vlan 99
switchport mode access
!
interface FastEthernet0/3
switchport mode access
!
interface FastEthernet0/4
switchport trunk native vlan 99
switchport mode trunk
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
switchport access vlan 20
switchport mode access
spanning-tree portfast
spanning-tree bpduguard enable
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
no ip address
shutdown
!
interface Vlan99
ip address 172.31.99.2 255.255.255.0

!


----------------



Switch 3


hostname S3
!
!
!
no ip domain-lookup
!
vtp mode transparent
!
!
spanning-tree mode pvst
spanning-tree vlan 20,40,60,80,99 priority 20480
!
vlan 10
!
vlan 20
!
vlan 30
!
vlan 40
!
vlan 50
!
vlan 60
!
vlan 70
!
vlan 80
!
vlan 99
!
interface FastEthernet0/1
switchport trunk native vlan 99
switchport mode trunk
!
interface FastEthernet0/2
switchport mode access
!
interface FastEthernet0/3
switchport trunk native vlan 99
switchport mode access
!
interface FastEthernet0/4
switchport trunk native vlan 99
switchport mode trunk
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
switchport access vlan 10
switchport mode access
spanning-tree portfast
spanning-tree bpduguard enable
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
no ip address
shutdown
!
interface Vlan99
ip address 172.31.99.3 255.255.255.0
!

!


STP port roles exercise

I loved the exercise. I messed up only on 2 ports: SW2 Fa0/2 and SW Fa0/3. I initially selected SW Fa0/3 as the designated port.

QUESTION:




CORRECTLY PLACED ROLE INDICATORS




Friday, June 3, 2016

Show VLAN commands from Cisco - summer reading list

TROUBLESHOOTNG VLANS:



Autostate troubleshooting:
http://www.cisco.com/c/en/us/support/docs/switches/catalyst-6500-series-switches/41141-188.html



Understanding L3 interfaces on switches
http://www.cisco.com/c/en/us/td/docs/switches/lan/catalyst4500/12-2/53SG/configuration/config/l3_int.pdf 

Autostate Feature in Catalyst Switches - The case of a missing Vlan Protocol Up notification

I was puzzled today by this piece of link-state-notification:

S2(config)#int f0/6
S2(config-if)#switchport mode access
S2(config-if)#switchport access vlan 99
S2(config-if)#int f0/11
S2(config-if)#switchport mode access
S2(config-if)#switchport access vlan 10
S2(config-if)#int f0/18
S2(config-if)#switchport mode access
S2(config-if)#switchport access vlan 99
S2(config-if)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan99, changed state to up


The reason I was puzzled was: why did the protocol stay down when I assigned port f0/6 to VLAN99? or port f0/11 to VLAN 10?

Ok, lets go to the best source...
Autostate Feature in Catalyst Switches 
http://www.cisco.com/c/en/us/support/docs/switches/catalyst-6500-series-switches/41141-188.html

Introduction
The autostate feature notifies a switch or routing module VLAN interface (Layer 3 (L3) interface) to transition toup/up status when at least one Layer 2 (L2) port becomes active in that VLAN.The router VLAN interfaces have to fulfill the following general conditions to be up/up:
  1. VLAN exists and is in active status on the switch VLAN database.
  2. VLAN interface exists on the router and is not administratively down.
  3. At least one L2 (access port or trunk) port exists and has a link up on this VLAN. The latest implementation of the autostate feature allows synchronization to Spanning-Tree Protocol (STP) port status.
A VLAN interface will be brought up after the L2 port has had time to converge (that is, transition from listening-learning to forwarding). This will prevent routing protocols and other features from using the VLAN interface as if it were fully operational. This also prevents other problems, such as routing black holes, from occurring.
At least one L2 (access port or trunk) port is in spanning-tree forwarding state on the VLAN.

LESSON 1: a misplaced port on VLAN 99

First, I investigated the link state for VLAN 99.

In my case, interface Vlan99 has been previously created with ip address 172.17.99.12 255.255.255.0. So, why didn't the line protocol come up after f0/6 was assigned to it? Why did it wait until f0/18? Will the line protocol stay up if I take down f0/18?

Checking what will happen if I take f0/18 off the VLAN

S2(config)#int f0/18
S2(config-if)#no switchport access vlan 99
S2(config-if)#

%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan99, changed state to down

So, it was the presence of a f0/18 that got the protocol to come up.

The protocol line state for the VLAN interfaces will come up when the first switchport belonging to the corresponding VLAN link comes up and is in spanning-tree forwarding state.

So, why is it not counting f0/6 as the first switchport to come up?

Troubleshooting the Autostate Feature on IOS Based Switches

checking STP (with only f0/6 is assigned to vlan 99)

S2(config-if)#do show spanning-tree vlan 99
No spanning tree instance exists.


No spanning tree??? Strange. Let's add f0/18 and re-check the spanning tree

S2(config)#int f0/18.
S2(config-if)#switchport access vlan 99
S2(config-if)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan99, changed state to up

 lets check out STP


But why doesn't STP mention my port f0/6? If it blocked it, I should see it here. Maybe something is wrong with the port. Checking the status of my f0/6.

S2#show int f0/6
FastEthernet0/6 is down, line protocol is down (disabled)

Checking my topology. Aha! my f0/6 should indeed be in Vlan 99, but on a different switch. DOLT!!!! S2 has no end devices attached to f0/6. That is why STP is not worrying about f0/6, and neither is VLAN 99.

So, the lesson to be learned from this story: 
If you write
S2(config-if)#switchport mode access
S2(config-if)#switchport access vlan 99
and there is no notification %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan99, changed state to up, then check your topology. You might be configuring the wrong port!


3.2.4.9 - VLAN Troubleshooting

3.2.4.9 - VLAN Troubleshooting






Final configurations for S1 and S2, with PC-A being assigned to LAN 20. PCs on VLAN 20 can ping each other

Switch 1

spanning-tree mode pvst
!
interface FastEthernet0/1
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
switchport access vlan 20
switchport mode access
!
interface FastEthernet0/7
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/8
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/9
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/10
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/11
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/12
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/13
switchport access vlan 20
switchport mode access
!
interface FastEthernet0/14
switchport access vlan 20
switchport mode access
!
interface FastEthernet0/15
switchport access vlan 20
switchport mode access
!
interface FastEthernet0/16
switchport access vlan 20
switchport mode access
!
interface FastEthernet0/17
switchport access vlan 20
switchport mode access
!
interface FastEthernet0/18
switchport access vlan 20
switchport mode access
!
interface FastEthernet0/19
switchport access vlan 30
switchport mode access
!
interface FastEthernet0/20
switchport access vlan 30
switchport mode access
!
interface FastEthernet0/21
switchport access vlan 30
switchport mode access
!
interface FastEthernet0/22
switchport access vlan 30
switchport mode access
!
interface FastEthernet0/23
switchport access vlan 30
switchport mode access
!
interface FastEthernet0/24
switchport access vlan 30
switchport mode access
!
interface GigabitEthernet0/1
switchport mode trunk
!
interface GigabitEthernet0/2
!
interface Vlan1
ip address 192.168.1.2 255.255.255.0

shutdown



Switch 2
spanning-tree mode pvst
!
interface FastEthernet0/1
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/7
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/8
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/9
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/10
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/11
switchport access vlan 20
switchport mode access
!
interface FastEthernet0/12
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/13
switchport access vlan 20
switchport mode access
!
interface FastEthernet0/14
switchport access vlan 20
switchport mode access
!
interface FastEthernet0/15
switchport access vlan 20
switchport mode access
!
interface FastEthernet0/16
switchport access vlan 20
switchport mode access
!
interface FastEthernet0/17
switchport access vlan 20
switchport mode access
!
interface FastEthernet0/18
switchport access vlan 20
switchport mode access
!
interface FastEthernet0/19
switchport access vlan 30
switchport mode access
!
interface FastEthernet0/20
switchport access vlan 30
switchport mode access
!
interface FastEthernet0/21
switchport access vlan 30
switchport mode access
!
interface FastEthernet0/22
switchport access vlan 30
switchport mode access
!
interface FastEthernet0/23
switchport access vlan 30
switchport mode access
!
interface FastEthernet0/24
switchport access vlan 30
switchport mode access
!
interface GigabitEthernet0/1
switchport mode trunk
!
interface GigabitEthernet0/2
!
interface Vlan1
ip address 192.168.1.3 255.255.255.0

shutdown

3.2.4.8 - Troubleshooting a VLAN Implementation Scenario 2

3.2.4.8 - Troubleshooting a VLAN Implementation Scenario 2




Objectives
Part 1: Find and Correct the Network Errors
Part 2: Document the Corrections to the Network
Part 3: Implement Solutions and Test Connectivity

Background 
In this activity, you will troubleshoot a misconfigured VLAN environment. The initial network has errors. Your objective is to locate and correct the errors in the configurations and establish end-to-end connectivity. Your final configuration should match the Topology diagram and Addressing Table. The native VLAN for this topology is VLAN 56.

Part 1: Discover and Document Issues in the Network Use the Topology, Addressing Table, VLAN and Port Assignments table and your knowledge of VLANs and trunking to discover issues in the network. Complete the Documentation table listing the problems you discovered and potential solutions.

PROBLEM SOLUTION
From show running-config
interface GigabitEthernet0/1
switchport trunk native vlan 56
switchport mode access
S2(config)# int g0/1
S2(config-if)#switchport mode trun
From show interface trunk
Native VLAN on S1 = Vlan1
Native VLAN on S2 = Vlan56
S1(config)#int g0/1
S1(config-if)#switchport trunk native vlan 56
From show interface trunk
Native VLAN on S1 = Vlan1
Native VLAN on S3 = Vlan56
S1(config)#int g0/2
S1(config-if)#switchport trunk native vlan 56
From show vlan:
All ports on S3 are assigned to Vlan1
S3(config)#int range f0/1-5
S3(config-if-range)#switchport mode access
S3(config-if-range)#switchport access vlan 56
S3(config-if-range)#exit
S3(config)#int range f0/6-10
S3(config-if-range)#switchport mode access
S3(config-if-range)#switchport access vlan 30
S3(config-if-range)#exit
S3(config)#int range f0/11-17
S3(config-if-range)#switchport mode access
S3(config-if-range)#switchport access vlan 10
S3(config-if-range)#exit
S3(config)#int range f0/18-24
S3(config-if-range)#switchport mode access
S3(config-if-range)#switchport access vlan 20
S3(config-if-range)#exit
From show interface trunk
S1 allowed VLANs in management domain lists only Vlan1
From show vlan: S1 does not have vlans 10, 20, 30, 56 created
S1(config)#vlan 10
S1(config-vlan)#name Faculty
S1(config-vlan)#exit
S1(config)#vlan 20
S1(config-vlan)#name Students
S1(config-vlan)#exit
S1(config)#vlan 30
S1(config-vlan)#name Guests
S1(config-vlan)#exit
S1(config)#vlan 56
S1(config-vlan)#
%LINK-5-CHANGED: Interface Vlan56, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan56, changed state to up
S1(config-vlan)#name Management&Native


Part 2: Implement the Solution and Test Connectivity
Verify PCs on the same VLAN can now ping each other. If not, continue to troubleshoot

- all PCs are now pinging PCs in their VLANs

------------------------

Switch 1
interface GigabitEthernet0/1
switchport trunk native vlan 56
switchport mode trunk
!
interface GigabitEthernet0/2
switchport trunk native vlan 56

switchport mode trunk


Switch 2

interface FastEthernet0/1
switchport access vlan 56
switchport trunk native vlan 56
switchport mode access
!
interface FastEthernet0/2
switchport access vlan 56
switchport trunk native vlan 56
switchport mode access
!
interface FastEthernet0/3
switchport access vlan 56
switchport trunk native vlan 56
switchport mode access
!
interface FastEthernet0/4
switchport access vlan 56
switchport trunk native vlan 56
switchport mode access
!
interface FastEthernet0/5
switchport access vlan 56
switchport trunk native vlan 56
switchport mode access
!
interface FastEthernet0/6
switchport access vlan 30
switchport mode access
!
interface FastEthernet0/7
switchport access vlan 30
switchport mode access
!
interface FastEthernet0/8
switchport access vlan 30
switchport mode access
!
interface FastEthernet0/9
switchport access vlan 30
switchport mode access
!
interface FastEthernet0/10
switchport access vlan 30
switchport mode access
!
interface FastEthernet0/11
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/12
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/13
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/14
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/15
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/16
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/17
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/18
switchport access vlan 20
switchport mode access
!
interface FastEthernet0/19
switchport access vlan 20
switchport mode access
!
interface FastEthernet0/20
switchport access vlan 20
switchport mode access
!
interface FastEthernet0/21
switchport access vlan 20
switchport mode access
!
interface FastEthernet0/22
switchport access vlan 20
switchport mode access
!
interface FastEthernet0/23
switchport access vlan 20
switchport mode access
!
interface FastEthernet0/24
switchport access vlan 20
switchport mode access
!
interface GigabitEthernet0/1
switchport trunk native vlan 56
switchport mode trunk
!
interface GigabitEthernet0/2
!
interface Vlan1
no ip address
shutdown
!
interface Vlan56

ip address 192.168.56.12 255.255.255.0


Switch 3

interface FastEthernet0/1
switchport access vlan 56
switchport mode access
!
interface FastEthernet0/2
switchport access vlan 56
switchport mode access
!
interface FastEthernet0/3
switchport access vlan 56
switchport mode access
!
interface FastEthernet0/4
switchport access vlan 56
switchport mode access
!
interface FastEthernet0/5
switchport access vlan 56
switchport mode access
!
interface FastEthernet0/6
switchport access vlan 30
switchport mode access
!
interface FastEthernet0/7
switchport access vlan 30
switchport mode access
!
interface FastEthernet0/8
switchport access vlan 30
switchport mode access
!
interface FastEthernet0/9
switchport access vlan 30
switchport mode access
!
interface FastEthernet0/10
switchport access vlan 30
switchport mode access
!
interface FastEthernet0/11
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/12
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/13
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/14
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/15
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/16
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/17
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/18
switchport access vlan 20
switchport mode access
!
interface FastEthernet0/19
switchport access vlan 20
switchport mode access
!
interface FastEthernet0/20
switchport access vlan 20
switchport mode access
!
interface FastEthernet0/21
switchport access vlan 20
switchport mode access
!
interface FastEthernet0/22
switchport access vlan 20
switchport mode access
!
interface FastEthernet0/23
switchport access vlan 20
switchport mode access
!
interface FastEthernet0/24
switchport access vlan 20
switchport mode access
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
switchport trunk native vlan 56
switchport mode trunk
!
interface Vlan1
no ip address
shutdown
!
interface Vlan56

ip address 192.168.56.13 255.255.255.0


3.2.4.9 - Troubleshooting a VLAN Implementation Scenario 1

3.2.4.9 - Troubleshooting a VLAN Implementation Scenario 1



Objectives

Part 1: Test Connectivity between PCs on the Same VLAN
Part 2: Investigate Connectivity Problems by Gathering Data
Part 3: Implement the Solution and Test Connectivity

Scenario

In this activity, you will troubleshoot connectivity problems between PCs on the same VLAN. The activity is complete when PCs on the same VLAN can ping each other. Any solution you implement must conform to the Addressing Table.


Part 1:     Test Connectivity between PCs on the Same VLAN

From the command prompt on each PC, ping between PCs on the same VLAN.

a.     Can PC1 ping PC4?
no

b.    Can PC2 ping PC5?
no

c.     Can PC3 ping PC6?
no

Part 2:     Investigate Connectivity Problems by Gathering Data

Step 1:     Verify configuration on the PCs.


Verify if the following configurations for each PC is correct.

·         IP address
·         Subnet mask

PC1 through PC4- correct (but missing gateways)
PC5- wrong IP addres



Step 2:     Verify the configuration on the switches.

Verify if the following configurations on the switches are correct.

·         Ports assigned to the correct VLANs.
·         Ports configured for the correct mode.
·         Ports connected to the correct devices.

Checking S1

S1#show running-conf

!
interface GigabitEthernet0/1
switchport trunk native vlan 99  - correct
switchport mode access -  incorrect
!
interface GigabitEthernet0/2
switchport trunk native vlan 99 - correct
switchport mode trunk - correct
!
interface Vlan1
no ip address

shutdown




Checking S2

S2#show vlan

VLAN Name Status Ports
---- -------------------------------- --------- -------------------------------
10 Faculty/Staff active- no ports assigned
20 Students active Fa0/18

30 Guest(Default) active Fa0/6, Fa0/11 - incorrect, should belong to VLAN 10


S2#show running-config
!
interface FastEthernet0/6
switchport access vlan 30 - correct
switchport mode access - correct
!
!
interface FastEthernet0/11
switchport access vlan 30 - incorrect
switchport mode access - correct
!
!
interface FastEthernet0/18
switchport access vlan 20 - correct
switchport mode access - correct
!
!
interface GigabitEthernet0/1
switchport trunk native vlan 99
switchport mode access - incorrect
!
!
interface Vlan1
no ip address

shutdown




Checking S3

S3#show vlan

VLAN Name Status Ports
---- -------------------------------- --------- -------------------------------
10 Faculty/Staff active Fa0/11
20 Students active Fa0/6 - incorrect, should be in VLAN 30
30 Guest(Default) active Fa0/18 - incorrect, should be in VLAN 10


S3#show run

!
interface FastEthernet0/6
switchport access vlan 20 - incorrect
switchport mode access - correct
!
interface FastEthernet0/11
switchport access vlan 10 - correct
switchport mode access - correct
!
!
interface FastEthernet0/18
switchport access vlan 30 - incorrect
switchport mode access - correct
!
interface GigabitEthernet0/2
switchport trunk native vlan 99 - correct
switchport mode trunk - correct
!
interface Vlan1
no ip address
shutdown

!

Step 3:     Document the problem and the solutions.

List the problems and the solutions that will allow these PCs to ping each other. Keep in mind that there could be more than one problem or more than one solution.

Int g0/1 on S2 is in access mode.
Correcting:

S2(config)#int g0/1

S2(config-if)#switchport mode trunk

S1(config)#int g0/1

S1(config-if)#switchport mode trunk


PC1 to PC4


a.     Explain the connectivity issues between PC1 and PC4.

Incorrect vlan assignment on S2 interface FastEthernet0/11


b.    Record the necessary actions to correct the issues.

S2(config)#int f0/11

S2(config-if)#switchport access vlan 10


PC2 to PC5


c.     Explain the connectivity issues between PC2 and PC5.

Incorrect vlan assignment on S3 interface FastEthernet0/18

d.    Record the necessary actions to correct the issues.

S3(config)#int f0/18

S3(config-if)#switchport access vlan 20

PC3 to PC6

e.     What are the reasons why connectivity failed between the PCs?
Incorrect IP assignment on PC 6
Incorrect vlan assignment on S3 interface FastEthernet0/6


f.     Record the necessary actions to correct the issues.

S3(config)#int f0/6

S3(config-if)#switchport access vlan 30


Part 3:     Implement the Solution and Test Connectivity

Verify PCs on the same VLAN can now ping each other. If not, continue to troubleshoot.

PC1 is pinging PC4
PC2 is not pinging PC5 (!!!!)
PC3 is pinging PC6

Troubleshooting

PCs on VLAN 20 are not talking

1. checking vlan assignment

S2(config)#do show vlan

VLAN Name Status Ports
---- -------------------------------- --------- -------------------------------
10 Faculty/Staff active Fa0/11 - correct
20 Students active Fa0/18 - correct

30 Guest(Default) active Fa0/6 - correct


S3(config)#do show vlan

VLAN Name Status Ports
---- -------------------------------- --------- -------------------------------
10 Faculty/Staff active Fa0/11 - correct
20 Students active Fa0/18 - correct

30 Guest(Default) active Fa0/6 - correct



2. Checking allowed vlans



S2(config)#do show interfaces trunk
Port Mode Encapsulation Status Native vlan
Gig0/1 on 802.1q trunking 99 - correct

Port Vlans allowed on trunk
Gig0/1 1-1005 - correct

Port Vlans allowed and active in management domain
Gig0/1 1,10,20,30,99 - correct

Port Vlans in spanning tree forwarding state and not pruned
Gig0/1 1,10,20,30,99 – correct
S3(config)#do show interface trunk
Port Mode Encapsulation Status Native vlan
Gig0/2 on 802.1q trunking 99 - correct

Port Vlans allowed on trunk
Gig0/2 1-1005 - correct

Port Vlans allowed and active in management domain
Gig0/2 1,10,20,30,99 - correct

Port Vlans in spanning tree forwarding state and not pruned
Gig0/2 1,10,20,30,99 – correct


S1#show interface trunk
Port Mode Encapsulation Status Native vlan
Gig0/1 on 802.1q trunking 99 - correct
Gig0/2 on 802.1q trunking 99 - correct

Port Vlans allowed on trunk
Gig0/1 1-1005 - correct
Gig0/2 1-1005 - correct

Port Vlans allowed and active in management domain
Gig0/1 1,10,20,30,99 - correct
Gig0/2 1,10,20,30,99 - correct

Port Vlans in spanning tree forwarding state and not pruned
Gig0/1 1,10,20,30,99  - correct
Gig0/2 1,10,20,30,99 - correct





3. Checking interfaces f0/18 on both sides


S2# show int f0/18
FastEthernet0/18 is up, line protocol is up (connected)

S3#show int f0/18
FastEthernet0/18 is down, line protocol is down (disabled)


4. Checking the links on S3

S3(config)#do show ip interface brief

FastEthernet0/16 unassigned YES manual down down

FastEthernet0/17 unassigned YES manual up up




FastEthernet0/18 unassigned YES manual down down


5. Checking topology:
Conclusion:
Topology label is incorrect. PC5 is actually connected to F0/17

Solution
Connect PC to f0/18 as specified in the topology

%LINK-5-CHANGED: Interface FastEthernet0/17, changed state to down

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/17, changed state to down

%LINK-5-CHANGED: Interface FastEthernet0/18, changed state to up


%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/18, changed state to up

Result
PC3 is now pinging PC6 successfully


Lab completed




--------------

Switch 1

spanning-tree mode pvst
!
interface FastEthernet0/1
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
switchport trunk native vlan 99
switchport mode trunk
!
interface GigabitEthernet0/2
switchport trunk native vlan 99
switchport mode trunk
!
interface Vlan1
no ip address

shutdown




Switch 2

spanning-tree mode pvst
!
interface FastEthernet0/1
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
switchport access vlan 30
switchport mode access
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
switchport access vlan 20
switchport mode access
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
switchport trunk native vlan 99
switchport mode trunk
!
interface GigabitEthernet0/2
!
interface Vlan1
no ip address

shutdown



Switch 3

spanning-tree mode pvst
!
interface FastEthernet0/1
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
switchport access vlan 30
switchport mode access
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
switchport access vlan 20
switchport mode access
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
switchport trunk native vlan 99
switchport mode trunk
!
interface Vlan1
no ip address
shutdown

!